Ad

Wednesday, April 23, 2008

Fixing the Station and Curve Report

One of my former coworkers wanted to have the Station and Curve report show station equation values in the correct format instead of in the decimal form. To do this open up the
C:\Program Files\Autodesk\LandXML Reporting 7\Support\xsl\Alignment Station and Curve.xsl
in your favorite text editing software or XML Notepad.

Near the top of the document there are three lines of text that write the station equation information to the html document. The three (3) lines are below:

<td><xsl:value-of select="@staInternal"/></td>
<td><xsl:value-of select="@staBack"/></td>
<td><xsl:value-of select="@staAhead"/></td>

If you go further down you will notice that other station type numbers have more information in them. For instance the start points of a line use this text:

<td><xsl:value-of select="landUtils:FormatStation(string($startStation), string($Alignment.Station.Display), string($Alignment.Station.precision), string($Alignment.Station.rounding))"/></td>

You will notice that "landUtils:FormatStation is included with a bunch of strings. The strings set the precision and format of the $startStation value in the first string. So we will need to add lines similar to the one above to the station equations. So the modified three line for the station equations should look like this:

<td><xsl:value-of select="landUtils:FormatStation(string(@staInternal), string($Alignment.Station.Display), string($Alignment.Station.precision), string($Alignment.Station.rounding))"/></td>
<td><xsl:value-of select="landUtils:FormatStation(string(@staBack), string($Alignment.Station.Display), string($Alignment.Station.precision), string($Alignment.Station.rounding))"/></td>
<td><xsl:value-of select="landUtils:FormatStation(string(@staAhead), string($Alignment.Station.Display), string($Alignment.Station.precision), string($Alignment.Station.rounding))"/></td>

Now when you run the report the station equations should be formatted as a station value instead of decimal form.

You will want to make sure you create a backup of the file in case you want to go back to the original report.

3 comments:

Anonymous said...

Give a try Edit Feature Settings - Alignment - Station. I have similar issue and got resorted out from here...

ahaninil said...

Couldn't find the file for Civil 3D 2013. Is there any way to fix the report in Civil 3D 2013?

Christopher Fugitt said...

Try C:\Program Files (x86)\Autodesk\LandXML Reporting 7\Support\xsl\Alignment Station and Curve.xsl

LinkWithin

Blog Widget by LinkWithin

Ad